Excel Intermediate: Complex Formulas and Charts

Overview: Expand your current Excel knowledge to include more complex formulas (including Year-to-Date formulas with cells from across spreadsheets), charts, naming worksheets and printing headers.

Student Skill Level: Intermediate

Requirements: Excel Basic class or familiarity with the program. Good mouse skills (ability to move the mouse on the computer screen and click or double click as required with minimal assistance).

Length: 3 hours (with a 10 minute break)

Objectives
- The student will be able to use an existing Excel workbook for the following:
  o Look at a collection tool and set up a workbook
  o Create Year-to-Date formulas across spreadsheets
  o Insert a chart based on data from a spreadsheet
The following is a simple form that could be used to collect responses regarding workshops. How would you “translate” this paper into the Excel format? It’s important to get all the data into the spreadsheet so that we can see how many workshops were done, dates, locations, etc. All of this information would be tallied so that a monthly report could be made. How would you do it?

Location Name: ___________________________ Date: ___________________________

Workshop Title: ________________________________________________________________

Trainer’s Name: ________________________________________________________________

How did you advertise this class? (For example, Flyer, Newspaper, Web Site, Other?)
______________________________________________________________________________

Please comment on the following **benefits** of hosting this workshop (check the box):

<table>
<thead>
<tr>
<th>Benefits</th>
<th>Strongly Disagree</th>
<th>Disagree</th>
<th>Neutral</th>
<th>Agree</th>
<th>Strongly Agree</th>
</tr>
</thead>
<tbody>
<tr>
<td>Attendees report satisfaction with program</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Booking computer training frees time for other duties</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Staff members had time to ask trainer questions and get computer assistance</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Trainer discussed future classes with staff and encouraged signup</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Interested in booking future training classes</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Please rate your **satisfaction** with the following (check the box):

<table>
<thead>
<tr>
<th>Satisfaction</th>
<th>Very Unsatisfied</th>
<th>Unsatisfied</th>
<th>Neutral</th>
<th>Satisfied</th>
<th>Very Satisfied</th>
</tr>
</thead>
<tbody>
<tr>
<td>Interaction with Trainer</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Ease of Booking Computer Training</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>BTOP Web Site Content - flyers, handouts, general information</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Materials &amp; Handouts</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Overall Satisfaction with the computer training program</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Please include additional comments about this program and/or how it may have made a difference to your patrons:

Once you have the questions in the sheet, you may use **Alt+Enter** to place a “hard return” in the cells (to make them take up less horizontal space).
Where to start: What data doesn’t change?

Every piece of paper is a person – and every person corresponds to a row in Excel. So, we’ll put the “unchanging” data across Row 1. Please USE THE TAB key to move from cell to cell. We’ll wrap the text so it looks right AFTER we’ve entered it. START IN CELL C1.

<p>| | | | | | | | | | | | | | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>C</td>
<td>D</td>
<td>E</td>
<td>F</td>
<td>G</td>
<td>H</td>
<td>I</td>
<td>J</td>
<td>K</td>
<td>L</td>
<td>M</td>
<td>N</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>---</td>
<td>---</td>
<td>---</td>
<td>---</td>
<td>---</td>
<td>---</td>
<td>---</td>
<td>---</td>
<td>---</td>
<td>---</td>
<td>---</td>
<td>---</td>
<td>---</td>
<td>---</td>
<td>---</td>
</tr>
<tr>
<td>Advertise?</td>
<td>Attendee: Training</td>
<td>Staff members</td>
<td>Trainer</td>
<td>di: You are in Interaction</td>
<td>Easy to use Web Site</td>
<td>Materials</td>
<td>Overall</td>
<td>Satisfaction</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

It looks messy here, but we’ll use **Wrap Text** to make it look better.

Select cells **C1 to N1** only.

Click on **Wrap Text** in the **Alignment** group on the Home tab, and this is what you’ll see:

Click on any blank cell on the spreadsheet to get rid of the selection (in blue). Change the column width to accommodate the words.
This is an example of how you may set up a spreadsheet to capture data. Next thing I would do is color-code the three separate areas of interest: **Benefits**, **Satisfaction**, and **Overall Satisfaction**.

Select the questions under **Benefits**

Click on the **Fill Color** command and choose a color (I go for lighter colors because they’re easier to read). Repeat this for **Satisfaction** and **Overall Satisfaction** cells.
**Prove It Test:** Since we have two main sections, let's add a row, label them, and use the **Merge and Center** option. We will also **Freeze** the top row.

Insert a new row one by **clicking on cell A1** and clicking on the **Home Tab > Cells group > Insert > Insert Sheet Rows**

Type “Benefits” in cell D1 and press Enter

Highlight D1 to H1

To merge and center the item, click the **Home Tab > Alignment Group > Merge and Center**

Do the same for cells I1 to L1, “Satisfaction.”

To freeze this row so it can be seen at all times, go to the **View Tab > Window Group > Freeze Top Row**.

This makes the top row visible no matter how far down you scroll.
Once you get a spreadsheet set up, you don’t want to keep having to set it up month after month. You may rename it then copy it.

**Right-click** the tab (labeled **Sheet 1** here) and click on the **Rename** command. (Alternately, you may double click the sheet name and type over it.)

**Sheet 1** will be selected (in black)

Type in **Draft** for the sheet name. This will be the generic sheet we will copy for the rest of the months.

Click once on the sheet to make the new name permanent.

**Right-click** again on the sheet name. This time choose the **Move or Copy** command.
Choose **move to end** and make sure you click **Create a copy**. Then click OK.

This will preserve the formatting we finished in the sheet.

---------Practice---------

Keep moving and creating copies of your generic **Month** spreadsheet. Please create spreadsheets up to June. Your workbook will look like this:

![Image of spreadsheet](image)

**Data Entry**

This is the most important, but probably most boring, part of creating the workbook. We will fill in January together, including formulas, and then we’ll switch over to a finished book. Here is an example:

![Image of data entry](image)
We will put in two formulas: a **count formula** in column **A** and an **average formula** in column **M**.

**COLUMN A FORMULA:**
It’s easiest to create the formulas in the following manner:

- Every formula begins with an equal sign
- **COUNTA** this is the proper formula to use when you are counting text items in cells

( open parenthesis

Now, use your mouse to select the cells you want to include in the formula (click and hold your mouse and drag over the cells you want).

) close parenthesis

When you do this correctly, press the **Enter key** on the keyboard. You should now see a number for your attendance for this particular class.

Repeat this pattern to get attendance numbers for the classes in January.

**COLUMN M FORMULA:**

- Every formula begins with an equal sign
- **AVERAGE** this is the proper formula to use when you are averaging numbers in cells

( open parenthesis

Now, use your mouse to select the cells you want to include in the formula (click and hold your mouse and drag over the cells you want).

) close parenthesis

Press **Enter**
Once the numbers are in, we have to summarize the entire month. Below is a way to do that.

Column **O** will contain our labels, and column **P** will have our formulas. These formulas will summarize our entire month.

Here’s the **attendance** formula. **Type a comma** between cells to select multiple, non-continuous cells.

Here’s the Overall Satisfaction **average** for the month of January

Here’s the final outcome

---

**Remember, all your monthly sheets will look like this.**
Year-to-Date Formulas

There are several ways to create YTD formulas. First, we’ll get our sheet to automatically update monthly attendance totals. Then, we’ll look at making a single formula that covers multiple spreadsheets. Here we see that the number of classes in January is simply counted “by hand” and typed in.

To get our monthly totals to automatically populate the YTD sheet, we can simply set up the sheet (as seen here) then add simple formulas.

The attendance in cell C3 is actually a **sum formula**, but with only one cell to be “added together.” The cell is from the January sheet, as indicated in the formula (Jan!).

By generating this formula, all changes in attendance will be tracked in the YTD sheet. Create this formula by:

- Clicking in cell C3
- Typing in =SUM(
- Clicking on the January spreadsheet
- Clicking on cell P4
- Type in the close parenthesis (Shift +0)
- Press Enter

**Alternative:** Don’t use a full formula. Just type in an equal sign, click the sheet, and click the cell you wish to “copy and paste.” Press Enter and you’re back to the YTD sheet.

The same thing can be done to tally the **monthly averages**.

For the YTD totals, just use a sum formula for attendance =SUM(C3:C8) and an average formula for the averages =AVERAGE(D3:D8)
You may also create a “double check” formula that creates an overall total for the 6 months represented in our spreadsheet. Here are the steps to follow:

Click in cell C11
Type in =SUM(
Click on the January spreadsheet
Click cell P4
Type in a comma
Click on February
Click cell P4
Type in a comma
Continue this pattern for each month.

Close parenthesis (Shift +0)
Press Enter

Insert a Chart

Let’s say we want to compare the total number of classes and attendance for these 6 months. We’ll select our data and use the Insert tab to choose a chart type.

This is a fairly simple chart: choose A3 to C8 for our chart information.

On the Insert tab, choose the Recommended Charts button. Click on the Clustered Column chart.
As seen below, the chart automatically inserts on the spreadsheet.

**Prove It Test:** to change a chart style, **click on the chart** and then click the **Design tab** at the top. Choose the chart style from the gallery.

Let’s change the legend on it.

Right-click once on a taller column and choose **Select Data** from the submenu.

Click on **Series 1** and **Edit**

Type the name **Classes** and click **OK**. Do the same for attendance.
**Resources**

**These items are available in the NIOGA Library System!**

**Contact your local library for assistance!**

<table>
<thead>
<tr>
<th>Call Number</th>
<th>Author</th>
<th>Title</th>
<th>Date</th>
</tr>
</thead>
<tbody>
<tr>
<td>005.54 HARV</td>
<td>Harvey, G</td>
<td>Excel 2010 for Dummies</td>
<td>2010</td>
</tr>
<tr>
<td>005.369 MCFE</td>
<td>McFedries, P</td>
<td>Teach Yourself Visually: Excel 2010</td>
<td>2010</td>
</tr>
<tr>
<td>005.446 RATH</td>
<td>Rathbone, A</td>
<td>Windows 7 &amp; Office 2010 for Dummies</td>
<td>2011</td>
</tr>
<tr>
<td>005.369 SHOU</td>
<td>Shoup, K</td>
<td>Office 2010 Simplified</td>
<td>2010</td>
</tr>
<tr>
<td>005.54 SYRS</td>
<td>Syrstad, T</td>
<td>Using Microsoft Excel 2010</td>
<td>2011</td>
</tr>
<tr>
<td>005.369 WEVE</td>
<td>Weverka, P</td>
<td>Office 2010 All-in-one for Dummies</td>
<td>2010</td>
</tr>
</tbody>
</table>

Edited 2018

Funding for computer training is provided by the Nioga Library System

------Additional Prove It Test Items------

To Center a selected worksheet both horizontally and vertically for printing: Page Layout > Page Setup > **Breakout arrow** > Margins > “Center on page” Horizontally and Vertically. Click OK.

To get each worksheet to print on one page: Page Layout > Page Setup > Breakout Arrow > Page > Scaling…. **Fit to 1 page wide by 1 page tall.**